Stay at The Club and Guest House - stay.theclub.ucsb.edu/ is down
Incident Report for UCSB-ARIT
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 05:11 PDT
Investigating
Service Outage Notification
Posted Sep 30, 2020 - 05:02 PDT
This incident affected: Club Essentials.